Let's please rename Block to Receiver before it's too late
Doug Lea
dl at cs.oswego.edu
Sat Jan 19 07:10:10 PST 2013
On 01/19/13 09:58, Tim Peierls wrote:
> I agree that "sink" doesn't emphasize the side-effect aspect, but does it really
> need to? What other use could a sink have? Whereas "action" doesn't carry any
> sense of "consuming" or "accepting".
Right. That's why it is nice in streams, but not in cases
where the connotation of consuming is just plain wrong --
the argument is just "used" not "consumed".
a.accept(x); b.accept(x); doSomethingElseWith(x);
My reason for preferring Action (or even Block!) to Sink
is that the only commonality is potential (and extremely
likely) side-effecting-ness.
(What would you name a void action of two arguments?
There are a lot of these now.)
-Doug
More information about the lambda-libs-spec-experts
mailing list