Let's please rename Block to Receiver before it's too late
Raab, Donald
Donald.Raab at gs.com
Tue Jan 22 13:59:39 PST 2013
The "collect" overlap and translation problem will happen with Groovy and Ruby developers as well.
One possible alternative name is "aggregate".
http://dictionary.reference.com/browse/aggregate?s=t
verb forms:
-"to bring together; collect into one sum, mass, or body."
-"to combine and form a collection or mass."
It would probably make sense then to rename Collector -> Aggregator and then accumulate -> aggregate and finally Collectors -> Aggregators.
public interface Collector<T, R> {
default boolean isConcurrent() { return false; }
R makeResult();
void accumulate(R result, T value);
R combine(R result, R other);
}
From: tpeierls at gmail.com [mailto:tpeierls at gmail.com] On Behalf Of Tim Peierls
Sent: Friday, January 18, 2013 5:26 PM
To: Raab, Donald [Tech]
Cc: Doug Lea; lambda-libs-spec-experts at openjdk.java.net
Subject: Re: Let's please rename Block to Receiver before it's too late
Please can we rename collect as well.
Whoa, steady -- I *like* collect. I see the overlap issue, but that really can't be allowed to stand in the way of a good name. What were you proposing instead?
--tim
More information about the lambda-libs-spec-experts
mailing list