tee()

Joe Bowbeer joe.bowbeer at gmail.com
Thu Jan 24 13:01:54 PST 2013


I agree that something like tee is needed for iterative development. The
name suggests a bifurcation though. peek seems more accurate.
On Jan 24, 2013 12:53 PM, "Brian Goetz" <brian.goetz at oracle.com> wrote:

> peek() is fine with me, and far more descriptive.
>
> Don convinced me of the need for this one when he described experiences
> his team had adapting to lazy collections in their libraries.
>
> On 1/24/2013 3:43 PM, Kevin Bourrillion wrote:
>
>> tee() stands out like a sore thumb.  I'm not surprised that Brian says
>> "this method is mostly for debugging."
>>
>> It just feels very, very strange to let the user inject a side-effect
>> into the middle of their stream somewhere, for mysterious hidden later
>> execution /maybe/.
>>
>> If it really must stay, I think I do like "peek" or "observe" over
>> "tee". But I would love to drop it.
>>
>> --
>> Kevin Bourrillion | Java Librarian | Google, Inc. |kevinb at google.com
>> <mailto:kevinb at google.com>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130124/9a19d080/attachment-0001.html 


More information about the lambda-libs-spec-experts mailing list