Function type naming conventions
Tim Peierls
tim at peierls.net
Thu Jan 24 14:47:59 PST 2013
On Thu, Jan 24, 2013 at 5:20 PM, Joe Bowbeer <joe.bowbeer at gmail.com> wrote:
> +1 ObjIntBlock (or a more descriptive "Block" name if one is selected)
>
Agreed.
Works well in conjunction with Dan Smith's suggestion ('if the base type is
parameterized in both its parameters and return, then the "To" prefix is
mandatory. If not, "To" is not used.'), omitting To and Bi where they
aren't needed.
--tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130124/cca9c4aa/attachment.html
More information about the lambda-libs-spec-experts
mailing list