tee()

Doug Lea dl at cs.oswego.edu
Fri Jan 25 04:51:18 PST 2013


On 01/25/13 03:44, Paul Sandoz wrote:
>
> On Jan 25, 2013, at 2:11 AM, Doug Lea <dl at cs.oswego.edu> wrote:
>
>> On 01/24/13 20:00, Joe Bowbeer wrote:
>>> I'm OK with peek() even though it has other meanings on IO streams.
>>>
>>> Is the name leak() is more to your liking?
>>
>> I can't think of a good name for the the little idiom of
>>   ....map(x -> { use(x); return x; })...
>>
>
> Although map affects the properties downstream in ways that tee/peek (observe?) does not.
>
> If the upstream is known to be sorted and/or distinct then the map operation will clear those properties so the downstream is not known to be sorted and/or distinct.


In which case tee() needs more than the usual number of disclaimers about
please not side-effecting the source...

And/or map() needs disclaimers about not knowing about
property-preserving-ness (which leads into some familiar
territory for Brian, Paul and me: who knows/tracks such
properties?)

-Doug




More information about the lambda-libs-spec-experts mailing list