Loose ends inventory
Brian Goetz
brian.goetz at oracle.com
Mon Jun 10 16:21:10 PDT 2013
Here's where things stand on the loose ends. When replying, PLEASE
separate into one mail per item, and change subject line!
> - Additional tweaking on range generators
This seems mostly converged; we've added rangeClosed() to range(),
eliminated the descending and step range support, dropped double ranges,
and dropped the proposal for ints() / longs() static methods. At the
same time, we renamed the instance ints() / longs() / doubles() methods
to asXxxStream().
> - Support for state-based cancelation (e.g., cancelWhen(BooleanSupplier))
Sad to let this one go, but it seems unlikely to make the cut.
> - Support for content-based limiting (takeWhile, skipUntil)
Sam will be sad to let this one go, but it seems unlikely to make the cut.
> - Post-transform on Collector, and related Collectors tweaks.
Still working on this, stay tuned.
> - Support for primitive stream concatenation
Seems settled.
> - zip
I think this one is heading for the YAGNI bin.
> - Additional static or default methods on standard SAMs?
What is currently in the jdk8 repositories is as far as I think we need
to go here; a very small number of static and default methods on
Function and friends.
> Point lambdafications
> - Gotta be more of these?
We added Ben Evans' regex splitAsStream().
> - Optional.{filter,map,flatMap}
Proposal under discussion.
> - Moving stream() / parallelStream() to Iterable
Proposal under discussion.
> - Comparators
Proposal under discussion.
> - Rename Spliterators.iteratorFromSpliterator to iterator.
Seems settled.
> - Pull up forEachRemaining from PrimitiveIterator.OfXxx into
PrimitiveIterator, a la Spliterator.OfPrimitive.
Seems settled.
> - Add A[] toArray(IntFunction<A[]> generator) to Collection.
Got stalled.
More information about the lambda-libs-spec-experts
mailing list