Collector / Collectors
Joe Bowbeer
joe.bowbeer at gmail.com
Wed Jun 19 13:11:23 PDT 2013
I hope to have this finished by Friday, but just in case here is something
I noticed on first glance:
toStringJoiner() appears at least twice in package overview, for example:
List<String> l = new ArrayList(Arrays.asList("one", "two"));
Stream<String> sl = l.stream();
l.add("three");
String s = sl.collect(toStringJoiner(" ")).toString();
On Wed, Jun 19, 2013 at 10:23 AM, Brian Goetz <brian.goetz at oracle.com>wrote:
> 24h in: no reviews yet. I guess I have to set a deadline: noon PT Friday.
>
>
> On 6/18/2013 11:58 AM, Brian Goetz wrote:
>
>> I think I may (finally!) have a final API candidate for Collector /
>> Collectors. Updated docs here:
>>
>> http://cr.openjdk.java.net/~**briangoetz/doctmp/doc/<http://cr.openjdk.java.net/~briangoetz/doctmp/doc/>
>>
>> Salient recent changes:
>> - Incorporation of finishing function into Collector
>> - Renamings in Collector API
>> - Morph toStringBuilder, toStringJoiner into joining()
>> - Add prefix/suffix version of joining()
>> - Addition of summingBy{Int,Long,Double}
>> - Addition of averagingBy{Int,Long,Double}
>> - Rename toXxxSummaryStatistics to summarizingXxx
>> - no-see reducing, and minBy/maxBy collectors return Optional
>> - elimination of canned merger functions from API
>>
>> Please review the API and spec. I have set up a SurveyMonkey with the
>> usual password to collect review comments at:
>>
>> https://www.surveymonkey.com/**s/3TTBJ7K<https://www.surveymonkey.com/s/3TTBJ7K>
>>
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130619/809acfbc/attachment.html
More information about the lambda-libs-spec-experts
mailing list