Loose ends inventory
Brian Goetz
brian.goetz at oracle.com
Wed Jun 26 10:29:46 PDT 2013
Update:
>> - Additional tweaking on range generators
Done.
>> - Support for state-based cancelation (e.g.,
>> cancelWhen(BooleanSupplier))
Punted.
>> - Support for content-based limiting (takeWhile, skipUntil)
Punted.
>> - Post-transform on Collector, and related Collectors tweaks.
Proposed design seems sound, proceeding. One or two remaining
mini-loose-ends (will cover these in more detail in a separate note):
- Means for combining Collector+Function into a Collector with a
finisher. This shows up in groupingBy scenarios.
- Extend Collector.of to allow setting of characteristics.
>> - Support for primitive stream concatenation
Done.
>> - zip
Punted.
>> Point lambdafications
Seems complete.
>> - Moving stream() / parallelStream() to Iterable
Reduced to spliterator() only. Presumed done unless someone comments on
spec in next day or two.
>> - Comparators
Done.
>> - Rename Spliterators.iteratorFromSpliterator to iterator.
Done.
>> - Pull up forEachRemaining from PrimitiveIterator.OfXxx into
> PrimitiveIterator, a la Spliterator.OfPrimitive.
Done
>> - Add A[] toArray(IntFunction<A[]> generator) to Collection.
Punted.
New item: resource release. Proposal under discussion.
More information about the lambda-libs-spec-experts
mailing list