> FWIW we could add range methods that takes one parameter: > > range(array.length) > > I think that would be better than indices. And only one is needed there rather than 9. Current plan, unless someone objects: - remove Arrays.indices() methods - add Arrays.fill() methods - add Streams.intRange(n) method as Paul suggests