> - add Arrays.fill() methods We have an unfortunate collection. We already have: void fill(Object[] a, Object val) { If we added <T> void fill(T[], IntFunction<T> gen) then existing calls to fill(array, null) would become ambiguous. Doh. (But the other 17 forms are not problematic.) Any suggestions for alternate names?