ConcurrentHashMap/ConcurrentMap/Map.compute
Doug Lea
dl at cs.oswego.edu
Fri Dec 7 08:36:33 PST 2012
On 12/07/12 11:28, Remi Forax wrote:
> I just don't like compute, the verb is too generic, update/updateValue is
> perhaps better.
I hated it too when Bob Lee et al lobbied for it, but enough years have
gone by that I often forget that I hate it :-)
Maybe this will happen to me some decade for "Block"...
(The main reason for keeping "compute" is the Guava precedence.)
-Doug
More information about the lambda-libs-spec-observers
mailing list