flatMap
Remi Forax
forax at univ-mlv.fr
Wed Dec 19 11:44:54 PST 2012
On 12/19/2012 08:37 PM, Brian Goetz wrote:
>> I think we should not use the name 'yield' because it can be a keyword
>> added later if we introduce coroutine, generator, etc.
>
> I thought of that. Then I realized we already have "Thread.yield"
> among others in the libraries, so there's no reason to use a
> suboptimal name just to avoid using the y-word.
>
> Are you saying that yieldInto is actually a *better* name? Or are you
> just trying to avoid a possible collision?
>
>
I like yieldInto, now there is perhaps a better name.
Rémi
More information about the lambda-libs-spec-observers
mailing list