Review Request: CR#8001634 : Initial set of lambda functional interfaces

Brian Goetz brian.goetz at oracle.com
Thu Nov 1 08:40:45 PDT 2012


> I also think that UnaryOperator and BinaryOperator are name that are too
> long,
> I think that Op and BinOp are better.

The names UnaryOperator and BinaryOperator are a bit inconsistent with 
the rest of the names.  The naming model we have (which may well be 
inadequate) implies a "natural" arity for a base name (arity(Predicate) 
= 1, arity(Factory) = 0).  We then use prefixes like Bi to suggest a 
different arity, such as in BiMapper or BiBlock.

So it would be more consistent to choose an arity for Operator (2?) and 
have Operator and UnaryOperator / UniOperator.  Do we like that better?

Or, is the "natural arity" scheme naive and we should have arity 
prefixes on all SAMs?  (I hope not.)


More information about the lambda-libs-spec-observers mailing list