Review Request: CR#8001634 : Initial set of lambda functional interfaces
Remi Forax
forax at univ-mlv.fr
Sun Nov 4 06:13:41 PST 2012
On 11/04/2012 03:06 PM, Doug Lea wrote:
> On 11/03/12 16:04, Brian Goetz wrote:
>> (Respond only if you *hate* block.)
>>
>
> As I first implied overly cutely, "block" is a heavily overloaded
> word. So, while it sounds OK in context, it will confuse people
> who aren't thinking about the context.
>
> The other term with plenty of precedent in Java and elsewhere is
> "Action". And seems not to have any odd overloadings.
> I'd be OK with it.
There is already several Action in swing/AWT land,
action listener + properties or desktop action.
>
> -Doug
>
Rémi
More information about the lambda-libs-spec-observers
mailing list