> Currently the idiom to sort a stream of Person by name is to call: > people.sorted(Comparators.comparing(Person::getName)) If this idiom is stuck with, maybe "comparing" could be renamed to "by". With a static import, this could read nicely: people.sorted(by(Person::getName)) Greg