Bikeshed opportunity: compose vs composeWith
Doug Lea
dl at cs.oswego.edu
Mon Nov 26 12:01:48 PST 2012
On 11/26/12 13:01, Brian Goetz wrote:
> We've got two changesets in flight that introduce a compose method:
>
> interface Function<T,R> {
> default<U> Function<T,U> compose(Function<R,U> other) { ... }
> }
>
>
> interface Comparator<T> {
> // create a dictionary-order comparator
> default Comparator<T> compose(Comparator<T> other) { ... }
> }
>
>
> We received some feedback that users found "compose()" at the use-site slightly
> ambiguous. I'm starting to lean towards "composeWith(fn)", despite it being
> slightly more wordy. Preferences?
>
If the question is: does f.compose(g) give you f applied to the result of g
or vice versa, I don't see how "composeWith" is any clearer -- it seems less
clear to me, especially since it differs for functions vs comparators.
For maximum clarity, spell it out?
Function<T,U> appliedToTheResultOf(Function<R,U> other)
Comparator<T> withSecondaryComparison(Comparator<T> other)
Perhaps someone can think of less awkward terms that spell it out
equally unambiguously.
-Doug
More information about the lambda-libs-spec-observers
mailing list