Dividing Streams.java
Brian Goetz
brian.goetz at oracle.com
Thu Apr 11 17:14:38 PDT 2013
I'm with Joe on this one. Because streams are new, people are looking
for the best way to get the stream they want, and often settle
(incorrectly) on "I guess I have to write a spliterator." Which is not
the best way to have a good experience.
We have the same problem with docs. There's a whole lot of
documentation (that needs to be written) for people writing
spliterators, that is totally confusing and overwhelming for people who
just want an integer range.
On 4/11/2013 7:01 PM, Joe Bowbeer wrote:
> But I am (and represent) Joe Programmer, and I've already complained :O
>
> At the top of the list is the confusing name doubleParallelStream, which
> does not create two parallel streams!
>
> It's very difficult to find anything useful in there, and the ones that
> take Spliterator arguments are a devil to figure out how to use, which
> adds to Joe's frustration.
>
> Simply removing everything that references a spliterator thing cleans it
> up a lot.
>
>
> On Thu, Apr 11, 2013 at 3:49 PM, Doug Lea <dl at cs.oswego.edu
> <mailto:dl at cs.oswego.edu>> wrote:
>
> On 04/11/13 13:51, Brian Goetz wrote:
>
> Joe quite correctly pointed out in the survey that Streams.java
> is a mix of two
> things for two audiences:
>
> - Utility methods for users to generate streams, like intRange()
> - Low level methods for library writers to generate streams
> from things like
> iterators or spliterators.
>
>
> I'm not too tempted by this. Classes Collections and Arrays have lots
> of stuff and people don't seem to complain.
>
> -Doug
>
>
More information about the lambda-libs-spec-observers
mailing list