Function type naming conventions
Brian Goetz
brian.goetz at oracle.com
Thu Jan 24 14:16:48 PST 2013
OK, I've completed:
- {Int,Long,Double}Function -> ToXxxFunction
- {Int,Long,Double}BiFunction -> ToXxxBiFunction
- Obj{Int,Long,Double}Function -> XxxFunction
The remaining weird ones are:
ObjIntBiBlock (T, int) -> void
These could stay ObjIntBiBlock, or, with the "arity unnecessary if all
args are specialized" rule tweak, could become:
ObjIntBlock
Thoughts?
On 1/24/2013 2:03 PM, Joe Bowbeer wrote:
> On Thu, Jan 24, 2013 at 10:52 AM, Dan Smith <daniel.smith at oracle.com
> <mailto:daniel.smith at oracle.com>> wrote:
>
> Let me propose a slightly different convention: if the base type is
> parameterized in both its parameters and return, then the "To"
> prefix is mandatory. If not, "To" is not used.
>
>
> This works for me if the base name is descriptive enough.
> IntSupplier, IntConsumer, even IntBlock (now that I know what a Block is).
>
> —Dan
>
>
More information about the lambda-libs-spec-observers
mailing list