Arrays methods
Paul Sandoz
paul.sandoz at oracle.com
Tue Mar 12 02:43:41 PDT 2013
On Mar 12, 2013, at 5:47 AM, bitter_fox <bitterfoxc at gmail.com> wrote:
> How is "fillByIndex"?
>
Seems OK to me, "fillUp" could be another choice.
Paul.
> I'm not a native speaker of English, so I don't know whether or not it's
> preferred by native speakers.
>
> Regards,
> bitter_fox
>
> 2013/3/12 Brian Goetz <brian.goetz at oracle.com>
>
>> - add Arrays.fill() methods
>>>
>>
>> We have an unfortunate collection. We already have:
>>
>> void fill(Object[] a, Object val) {
>>
>> If we added
>>
>> <T> void fill(T[], IntFunction<T> gen)
>>
>> then existing calls to
>>
>> fill(array, null)
>>
>> would become ambiguous. Doh. (But the other 17 forms are not
>> problematic.)
>>
>> Any suggestions for alternate names?
>>
More information about the lambda-libs-spec-observers
mailing list