Hiding the lambda proxy frame
Daniel_Heidinga at ca.ibm.com
Wed Jun 12 13:41:43 PDT 2013
The more pressing concern from the presentation is whether the source file
and line number for the lambda is correct. Ensuring we get this right
makes a lot of sense.
A stacktrace is a powerful tool for debugging and allowing frames to be
hidden decreases the value of the stacktrace. With this behaviour change,
the stacktrace and debugger will disagree on what the stack looks like -
which is needlessly confusing. Personally, I hate having my debugging
tools lie to me so I'd rather see accurate stacktraces.
An annotation that hides stack frames is too easy to abuse, even if you
have the best of intentions (like hiding implementation details). It will
be over-used and lead to significant difficulties in finding where errors
How hidden are LambdaForms$Hidden frames? Are they only hidden from
stacktraces or do APIs like sun.reflect.Reflection.getCallerClass() also
skip these hidden frames?
> On 06/11/2013 03:22 PM, Brian Goetz wrote:
> > Why wouldn't you bring this to the EG list instead?
> Sure, it was an implementation detail for me, hence the post on
> So from lambda-dev:
> Currently when you print a stacktrace that show a call inside a lambda,
> users can see the the frame corresponding to the method of the generated
> By example:
> StackTraceTest$$Lambda$1.run(Unknown Source) <--- ugly, isn't
> I think this line should not be visible to user, it doesn't provide
> useful information,
> just make the stack trace longer than it should.
> There is an annotation LambdaForm.Hidden that you can use to mark method
> that should be hidden when dumping the stack trace.
> (Maybe the annotation should be a top-level by the way, add John in CC
> he is the creator of this annotation)
> This part was not in the original mail:
> Moreover, offline, one of my friend point me to a presentation of Jamie
> on the same subject at JAXConf 2013. I've just finished to see it.
> He raises a good point that the compiler translation should try to
> provide a better name.
> By example,
> Runnable myRunnable = () -> System.out.println("hello");
> should result in a lambda that instead to be called "lambda$0",
> instead the compiler should try to name it something like lambda
> (or lambda$myRunnable0, ..., if there is a collision) if it's possible.
> I think we already discuss about something like that in the light of
> but not in the stack trace context.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the lambda-spec-experts