Cannot build loom jdk after recent changes

Cay Horstmann cay.horstmann at
Sun Dec 15 20:14:04 UTC 2019

It's good to see lots of people trying the build. I just pulled the 
latest changes and rebuilt, and it went ok.

I am building on Ubuntu 18.04 and set JDK_HOME and JAVA_HOME to my JDK13 

What platform are you building on?



Il 15/12/19 20:47, Arkadiusz Gasiński ha scritto:
> Hi,
> Thanks, Alan. Switched to master, tried rebuilding and got the same error.
> I think it's not actually a compile error that causes the build to fail,
> but rather this -Werror option that is specified somewhere but haven't
> found where yet.
> Thanks,
> Arek
> On Sun, Dec 15, 2019 at 8:35 PM Alan Bateman <Alan.Bateman at>
> wrote:
>> On 15/12/2019 18:33, Arkadiusz Gasiński wrote:
>>> Hi,
>>> I pulled yesterday's changes and wanted to re-build the loom JDK, but the
>>> build keeps failing with the below error. All hints appreciated.
>> The loom repo was sync'ed up to jdk-14+27 so a lot of changes from
>> upstream and a lot of complex merging. All the build configurations on
>> linux-x64, macosx-x64, and windows-x64 should be okay.  Are you able to
>> build the master branch? That might work as a control in your
>> environment to makes sure that you can build before trying the fibers
>> branch.
>> -Alan

More information about the loom-dev mailing list