draft Carrier API

John Rose john.r.rose at oracle.com
Fri Mar 6 20:56:28 UTC 2020

On Mar 6, 2020, at 7:21 AM, Doug Lea <dl at cs.oswego.edu> wrote:
> Suggestions and comments are welcome.

One very vague comment:

This design puts both endpoints on one type, as opposed
to two similar types, like InputStream and OutputStream.
This leads to fewer types and objects (good) but broader ones.
Broader is little less good, since most use points only care
about 1/2 of the methods; the other 1/2 is then noise.

It would be nice to see an overall policy statement about this.

— John

More information about the loom-dev mailing list