RFR: Some more descriptive names, removed redundant asserts. Request for comments. [v3]
Coleen Phillimore
coleenp at openjdk.java.net
Wed Apr 6 02:20:27 UTC 2022
> Also, there's an if statement already for chunk_available which the compiler shouldn't have trouble optimizing. Otherwise we should refactor freeze_fast.
> Tested locally with make test TEST=jdk/jdk/internal/vm/Continuation since only names.
Coleen Phillimore has updated the pull request incrementally with one additional commit since the last revision:
More questions
-------------
Changes:
- all: https://git.openjdk.java.net/loom/pull/139/files
- new: https://git.openjdk.java.net/loom/pull/139/files/4d915177..bcd29371
Webrevs:
- full: https://webrevs.openjdk.java.net/?repo=loom&pr=139&range=02
- incr: https://webrevs.openjdk.java.net/?repo=loom&pr=139&range=01-02
Stats: 28 lines in 1 file changed: 17 ins; 9 del; 2 mod
Patch: https://git.openjdk.java.net/loom/pull/139.diff
Fetch: git fetch https://git.openjdk.java.net/loom pull/139/head:pull/139
PR: https://git.openjdk.java.net/loom/pull/139
More information about the loom-dev
mailing list