RFR: First refactoring (thaw_fast)

Coleen Phillimore coleenp at openjdk.java.net
Wed Apr 20 18:15:56 UTC 2022


On Wed, 20 Apr 2022 17:49:29 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:

>> Refactoring method thaw_fast() for better encapsulation and readability.
>
> src/hotspot/share/oops/stackChunkOop.inline.hpp line 179:
> 
>> 177:   bool empty = false;
>> 178:   StackChunkFrameStream<ChunkFrames::CompiledOnly> f(this);
>> 179:   intptr_t* const chunk_sp = start_address() + sp();
> 
> This derelativizes the sp() doesn't it?

chunk_sp is only used for asserts? Not that I think it should go into messy DEBUG_ONLY conditionals though.  Maybe these asserts should go into StackChunkFrameStream instead?

-------------

PR: https://git.openjdk.java.net/loom/pull/158


More information about the loom-dev mailing list