Review request for JDK-8006191
A. Sundararajan
sundararajan.athijegannathan at oracle.com
Mon Feb 4 03:00:51 PST 2013
Looks good - few changes suggested:
* Global.java - exec_name for local variable name. We don't use _ names
for locals
* ScriptingFunctions.java - the exec function may just throw
IOException, InterupptedException etc. let the script caller deal with
exceptions by try..catch (if desired)
* $ starting names in ScriptingFunctions.exec - I think $ starting names
are reserved for tools like javac and other compile time tools. Better
to avoid the same. Script variable names are fine. (i.e., $ starting
names for script global vars are fine).
-Sundar
On Saturday 02 February 2013 09:51 PM, Jim Laskey (Oracle) wrote:
> Please review http://cr.openjdk.java.net/~jlaskey/8006191/webrev.00/index.html
>
> Cheers,
>
> -- Jim
>
More information about the nashorn-dev
mailing list