Request for comments: Bug 6306820
Michael McMahon
Michael.McMahon at Sun.COM
Thu Jun 28 08:30:06 PDT 2007
Some other minor comments on the last draft.
- Michael.
Class intro docs.
1. In the section entitled "Multivalued parameters" the list refers to
getParameterValue()
This should be getParameter()
2. The first reference to "(ampersand and semicolon)" should inlcude the
actual symbols
themselves for clarity eg. (ampersand "&" and semicolon ";")
3. I'd remove the section about URL. There is no need to mention it at all.
4. Section on Thread Safety. Change "not safe for use by multiple
threads" to just
"not synchronized".
Other comments on the method definitions
5. If the use of [] arrays is being changed to List<>, then any of the
methods that take
these as parameters: create() , getParameterMap().
6. Why does the parse() method say that calling it with an invalid
string, is undefined?
Would it not be better to throw an exception with an invalid string?
Same comment applies to other methods with similar spec.
7. The notes in italics referring to servlet should be removed I think.
8. I think the docs for the 2nd setParameter() variant should say
something different
from the 1st one. Maybe an example showing how a literal or
primitive integer type
would be accepted as an argument.
More information about the net-dev
mailing list