please review 7018392, update URLJarFile.java to use try-with-resources
Alan Bateman
Alan.Bateman at oracle.com
Fri Feb 11 04:27:20 PST 2011
Chris Hegarty wrote:
> Stuart,
>
> Thanks for doing this. The new code looks much cleaner. Please go
> ahead and push this change.
>
> -Chris.
Looks okay to me too. One minor comment is that it might be slightly
easier to read if it were:
File tmpFile = File.createTempFile("jar_cache", null);
try {
:
} finally {
if (jarFile != null) tmpFile.delete();
}
-Alan.
More information about the net-dev
mailing list