RFR: 8233296: MulticastSocket getOption/setOption inverts the value of IP_MULTICAST_LOOP

Daniel Fuchs daniel.fuchs at oracle.com
Fri Nov 22 11:14:50 UTC 2019


Thanks Alan!

On 21/11/2019 21:15, Alan Bateman wrote:
> I think I would cast to boolean rather than Boolean (because it's 
> boolean on the LHS) to make it a bit clearer. The rest looks good.

OK - I'll do that before pushing.

Although for me, given an Object obj, it's actually more natural to do:
    boolean x = (Boolean) obj;
than
    boolean x = (boolean) obj;

and FWIW there are other places in this file that do things like:

    int x = ((Integer)value).intValue();

(which I don't like much but won't touch in this patch)

best regards,

-- daniel
> 
> I see Joe has just approved the CSR and agrees with the suggestion that 
> this should be back-ported to ensure future use of this API doesn't 
> create a migration issue.
> 
> -Alan.



More information about the net-dev mailing list