RFR: 8291226: Create Test Cases to cover scenarios for JDK-8278067 [v10]
Ramesh Bhagavatam Gangadhar
rgangadhar at openjdk.org
Fri Aug 26 14:59:01 UTC 2022
On Tue, 23 Aug 2022 13:37:58 GMT, Daniel Fuchs <dfuchs at openjdk.org> wrote:
>> Ramesh Bhagavatam Gangadhar has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 10 additional commits since the last revision:
>>
>> - Merge branch 'openjdk:master' into 8291226
>> - Merge branch 'openjdk:master' into 8291226
>> - aligned imports and removed whitespaces
>> - Removed additional whitespaces
>> - Renamed method names
>>
>> renamed method createServer name to executeServer
>> - Update KeepAliveTest.java
>>
>> Removed White Spaces
>> - Update KeepAliveTest.java
>>
>> Renamed Methods like startScenario, runClient, startServer, connectToServerURL
>> added final to constants
>> Changed clientScenarios array
>> Changed serverScenarios array
>> added IllegalArgumentException
>> Replaced TIMEOUT with CountDownLatch
>> Added Comments
>> - Update and rename KeepAliveTest to KeepAliveTest.java
>>
>> 1. Increased space from 2 to 4.
>> 2. skipped test scenarios from 113 to 128 && 145 to 160
>> - Merge branch 'openjdk:master' into 8291226
>> - Create KeepAliveTest
>
> test/jdk/sun/net/www/http/HttpClient/KeepAliveTest.java line 337:
>
>> 335: private String getServerScenario(int scenarioNumber) {
>> 336: if(scenarioNumber >= 0 && scenarioNumber <= 15) {
>> 337: return A;
>
> might be good to have a comment before each return statement that shortly describe what the returned scenario is about.
this is done @dfuch thanks also i have documented each and every scenario in the form of table.
> test/jdk/sun/net/www/http/HttpClient/KeepAliveTest.java line 547:
>
>> 545: private void fetchInfo(int scenarioNumber, sun.net.www.protocol.http.HttpURLConnection httpUrlConnection)
>> 546: throws Exception {
>> 547: Field field = Class.forName("sun.net.www.protocol.http.HttpURLConnection").getDeclaredField("http");
>
> Strange tabs here: eight spaces should be enough for a method body.
yes removed additional spaces @dfuch thanks
-------------
PR: https://git.openjdk.org/jdk/pull/9958
More information about the net-dev
mailing list