RFR: 8294047: HttpResponseInputStream swallows interrupts

Daniel Fuchs dfuchs at openjdk.org
Thu Nov 24 17:08:02 UTC 2022


On Thu, 24 Nov 2022 16:36:51 GMT, Darragh Clarke <duke at openjdk.org> wrote:

>> test/jdk/java/net/httpclient/HttpResponseInputStreamInterruptTest.java line 107:
>> 
>>> 105:     static class Handler implements HttpHandler {
>>> 106: 
>>> 107:         CountDownLatch countDownLatch;
>> 
>> Maybe a better name than `countDownLatch` could be found - that could give a clue on what this latch is used to wait for?
>
> I was thinking maybe `messageLatch`, `messageReceivedLatch` or `clientReadyLatch`

Maybe we rename both:

countDownLatch  => interruptReadyLatch
interruptLatch  => interruptDoneLatch

-------------

PR: https://git.openjdk.org/jdk/pull/11323


More information about the net-dev mailing list