RFR: 8301964: Expensive fillInStackTrace operation in HttpURLConnection.getLastModified when no last-modified in response [v2]

Andrey Turbanov aturbanov at openjdk.org
Tue Feb 7 13:01:59 UTC 2023


On Tue, 7 Feb 2023 11:05:04 GMT, Alan Bateman <alanb at openjdk.org> wrote:

>> Andrey Turbanov has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   8301964: Expensive fillInStackTrace operation in HttpURLConnection.getLastModified when no last-modified in response
>>   
>>   rename Default to defaultValue
>
> src/java.base/share/classes/java/net/HttpURLConnection.java line 609:
> 
>> 607:             }
>> 608:             try {
>> 609:                 return Date.parse(dateString);
> 
> Changing this method makes me wonder if we should replace the Date.parse usage with DateTimeFormatter while we are there, also the parameter name "Default" wants to be renamed too.

I've renamed `Default` to `defaultValue`.
Regarding Date.parse replacement: I think it's a quite non-trivial task, which deserves a separate issue. As I see, there already was issue created and closed as Won't Fix - [JDK-4097762](https://bugs.openjdk.org/browse/JDK-4097762)

-------------

PR: https://git.openjdk.org/jdk/pull/12451


More information about the net-dev mailing list