RFR: 8331195: Improve com.sun.net.httpserver.HttpExchange usability [v3]

Daniel Fuchs dfuchs at openjdk.org
Tue Apr 30 16:07:04 UTC 2024


On Tue, 30 Apr 2024 15:55:05 GMT, robert engels <duke at openjdk.org> wrote:

>> src/jdk.httpserver/share/classes/com/sun/net/httpserver/HttpExchange.java line 237:
>> 
>>> 235:      */
>>> 236:     public final OutputStream sendResponseHeadersChunked(int code) throws IOException {
>>> 237:         sendResponseHeaders(code,CHUNKED_CONTENT);
>> 
>> I don't like the fact that this methor returns an `OutputStream` when other `sendResponseXxx` methods return `void`. IMO it should either be renamed or the return type changed to `void`, or maybe it should simply be dropped.
>
> The purpose was that if you state you are sending a chunked response, you must close the output stream. By returning it - the linter will catch that it is closed, or used in a try-with-resources.

I understand - but in this case we need a different (better?) name.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18955#discussion_r1585112476


More information about the net-dev mailing list