RFR: 8350279: HttpClient: Add a new HttpResponse method to identify connections

Volkan Yazici vyazici at openjdk.org
Fri Mar 21 13:51:32 UTC 2025


Adds `HttpResponse::connectionLabel` method that provides an identifier for the connection.

**Implementation note:** The feature is facilitated by `HttpConnection::label`, which should not be confused with `HttpConnection::id`. This distinction is explained in the JavaDoc of both properties.

-------------

Commit messages:
 - Rename `HttpConnection::connectionLabel` to `label`
 - Revert `HttpClientImpl` changes
 - Replace radix-62 usage with plain numbers
 - Rename `HttpConnection::connectionId` to `connectionLabel`
 - Fix code typo in `HttpConnection::connectionLabel`
 - Switch to old style JavaDoc in `HttpResponse`
 - Add `HttpConnection::connectionId` and use that for `::connectionLabel`
 - Initial `HttpResponse::connectionLabel` draft

Changes: https://git.openjdk.org/jdk/pull/24154/files
  Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=24154&range=00
  Issue: https://bugs.openjdk.org/browse/JDK-8350279
  Stats: 557 lines in 12 files changed: 523 ins; 2 del; 32 mod
  Patch: https://git.openjdk.org/jdk/pull/24154.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/24154/head:pull/24154

PR: https://git.openjdk.org/jdk/pull/24154


More information about the net-dev mailing list