<html><head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>
<body>
On 07/02/2023 20:06, DiCroce, Richard wrote:<br>
<blockquote type="cite" cite="mid:DM5PR05MB3323934EB96432C89C9CF6E580DB9@DM5PR05MB3323.namprd05.prod.outlook.com">
<meta name="Generator" content="Microsoft Word 15 (filtered
medium)">
<!--[if !mso]><style>v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style><![endif]-->
<style>@font-face
{font-family:"Cambria Math";
panose-1:2 4 5 3 5 4 6 3 2 4;}@font-face
{font-family:Calibri;
panose-1:2 15 5 2 2 2 4 3 2 4;}p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0in;
font-size:11.0pt;
font-family:"Calibri",sans-serif;}span.EmailStyle17
{mso-style-type:personal-compose;
font-family:"Calibri",sans-serif;
color:windowtext;}.MsoChpDefault
{mso-style-type:export-only;}div.WordSection1
{page:WordSection1;}</style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
<div class="WordSection1">:<o:p></o:p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I’d also like to get your thoughts on a
possible second patch that would be more extensive and might
contain some functional changes. The current code is a little
messy and uses some ancient APIs. Some initial experiments
suggest that newer APIs (available since Vista/Server 2008)
would be faster. The current code also invents its own
interface naming scheme. Windows now has APIs for that (e.g.
ConvertInterfaceLuidToNameW), but switching to those would
obviously mean that getName() would return a different value
than it does today. getByName() would also need to be
adjusted, but I could code it such that it tries the Windows
APIs first and then falls back to the existing code, in order
to minimize breakage. So, given those caveats, do you think
such a patch would have any chance of being accepted? Or would
any breaking changes be a no-go?<o:p></o:p></p>
<br>
</div>
</blockquote>
I think it would be good to use the Windows interface names. The
reason for the netNNN names is that there wasn't any Win32 APIs to
get interface names when this code was originally written for JDK
1.4. It should have been re-visited a long time ago. That said, I
think NetworkInterface is a good candidate to re-implement
completely in Java using the Panama FFM API so that the existing JNI
code can go away. As always, the main issues are getting Reviewer
cycles and testing to make sure that there aren't any regressions in
unusual configurations. So I think start with the performance
improvement at least.<br>
<br>
-Alan<br>
</body>
</html>