Swap should be better done native?

Ulf Zibis Ulf.Zibis at gmx.de
Fri Apr 2 15:42:11 PDT 2010


Am 02.04.2010 19:50, schrieb Ulf Zibis:
> Am 02.04.2010 16:13, schrieb Ulf Zibis:
>> Am 02.04.2010 02:04, schrieb Ulf Zibis:
>>> Am 01.04.2010 01:29, schrieb Martin Buchholz:
>>>> On Wed, Mar 31, 2010 at 16:11, Ulf Zibis<Ulf.Zibis at gmx.de>  wrote:
>>>>> Not to forget java.nio.Heap-X-Buffer.java.template.
>>>> Ulf, would you like to provide a patch that deletes all uses of
>>>> java.nio.Bits.swap and replaces them with the relevant
>>>> reverseBytes methods?
>>>
>>> See attachments.
>>>
>>> Number_reverseBytes:
>>> - Most, but not all, i.e. Float, Double, SIZE constants were at 
>>> "wrong" position. I have corrected this.
>>> - I too think, serialVersionIDs should be positioned more upper, 
>>> e.g. as last of all static finals.
>>>
>>> X-Buffer_swap:
>>> - I'm not enough experienced in make files, and I can't run them on 
>>> my Windows system, so genBuffer.sh change is incomplete.
>>>
>>
>> X-Buffer_swap2:
>> - Removed superfluous casts and bloated white space.
>

X-Buffer_swap3:
- Use more descriptive names

Alternatively I think we would better have separate classes for 
DirectByteBufferX e.g.:
- DirectByteBuffer
- DirectByteBufferR
- DirectUnalignedByteBuffer  (unalignedAccessible)
- DirectUnalignedByteBufferR  (unalignedAccessible)

-Ulf

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: X-Buffer_swap3
Url: http://mail.openjdk.java.net/pipermail/nio-dev/attachments/20100403/d9ccb6f5/attachment.ksh 


More information about the nio-dev mailing list