5071718: (bf) Add ByteBuffer.slice(int offset, int length)
Brian Burkhalter
brian.burkhalter at oracle.com
Tue Feb 26 17:30:46 UTC 2019
Hi Roger,
> On Feb 26, 2019, at 8:46 AM, Roger Riggs <Roger.Riggs at oracle.com> wrote:
>
> Nice updates.
Thanks.
> CSR:
>
> The summary line should stand on it own.
> It should explicitly mention ByteBuffer or XXXBuffer by name and name the new method. For example.
>
> "Add a slice method to ByteBuffer and Buffer to create a subsequence given an absolute position and size.”
Changed to
"Add a slice method to Buffer and its type specific subclasses to create a subsequence given an absolute position and size.”
> I would use present tense instead of future tense.
> The future tense could be read as being indefinite about when that is true.
> "will be" -> "are"
> But it is consistent with existing methods.
>
> Buffer.java: 141: it looks odd to have capital "It" after ":"
Both of the above are consistent with existing javadoc so I don’t know that the new text should differ.
Thanks,
Brian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.java.net/pipermail/nio-dev/attachments/20190226/1dcb67c8/attachment.html>
More information about the nio-dev
mailing list