RFR: 8219014: (bf) Add absolute bulk put methods which accept a source Buffer
Alan Bateman
alanb at openjdk.java.net
Tue Nov 3 12:10:56 UTC 2020
On Fri, 30 Oct 2020 20:37:53 GMT, Brian Burkhalter <bpb at openjdk.org> wrote:
> Please review this proposed fix. The previous incarnation of this review was most recently in mail threads [1, 2] under the old Hg SCM. The implementation changes proposed here are derived from the final (.02) patch posted in [1]. The corresponding CSR is [3].
>
> The essence of the change is to move the bulk put buffer core functionality to a new method putBuffer(), modify the existing relative bulk put buffer method to call it, and add a new absolute bulk put buffer method which also calls it. The existing test for bulk put buffer functionality is modified to verify the new API.
>
> This change builds on the work completed for JDK-5029431 (bulk put and get using an array) and JDK-8245121 (relative bulk put buffer with overlapping regions).
>
> [1] http://mail.openjdk.java.net/pipermail/nio-dev/2020-June/007340.html
> [2] http://mail.openjdk.java.net/pipermail/nio-dev/2020-July/007344.html
> [3] https://bugs.openjdk.java.net/browse/JDK-8248431
Marked as reviewed by alanb (Reviewer).
src/java.base/share/classes/java/nio/X-Buffer.java.template line 1013:
> 1011: *
> 1012: * @throws ReadOnlyBufferException
> 1013: * If this buffer is read-only
Can you align the parameter and throws descriptions so they are consistent with the other methods?
test/jdk/java/nio/Buffer/BulkPutBuffer.java line 327:
> 325:
> 326: private static void expectThrows(Class exClass,
> 327: Assert.ThrowingRunnable r) {
Spurious line break in method declaration, also exClass should be Class<?>
-------------
PR: https://git.openjdk.java.net/jdk/pull/969
More information about the nio-dev
mailing list