RFR: 8219014: (bf) Add absolute bulk put methods which accept a source Buffer [v2]
Brian Burkhalter
bpb at openjdk.java.net
Tue Nov 3 18:10:13 UTC 2020
> Please review this proposed fix. The previous incarnation of this review was most recently in mail threads [1, 2] under the old Hg SCM. The implementation changes proposed here are derived from the final (.02) patch posted in [1]. The corresponding CSR is [3].
>
> The essence of the change is to move the bulk put buffer core functionality to a new method putBuffer(), modify the existing relative bulk put buffer method to call it, and add a new absolute bulk put buffer method which also calls it. The existing test for bulk put buffer functionality is modified to verify the new API.
>
> This change builds on the work completed for JDK-5029431 (bulk put and get using an array) and JDK-8245121 (relative bulk put buffer with overlapping regions).
>
> [1] http://mail.openjdk.java.net/pipermail/nio-dev/2020-June/007340.html
> [2] http://mail.openjdk.java.net/pipermail/nio-dev/2020-July/007344.html
> [3] https://bugs.openjdk.java.net/browse/JDK-8248431
Brian Burkhalter has updated the pull request incrementally with one additional commit since the last revision:
8219014: (bf) Add absolute bulk put methods which accept a source Buffer
-------------
Changes:
- all: https://git.openjdk.java.net/jdk/pull/969/files
- new: https://git.openjdk.java.net/jdk/pull/969/files/1cfc8aba..12e4ddf5
Webrevs:
- full: https://webrevs.openjdk.java.net/?repo=jdk&pr=969&range=01
- incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=969&range=00-01
Stats: 13 lines in 2 files changed: 0 ins; 1 del; 12 mod
Patch: https://git.openjdk.java.net/jdk/pull/969.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/969/head:pull/969
PR: https://git.openjdk.java.net/jdk/pull/969
More information about the nio-dev
mailing list