invokeAndWait
Hendrik Ebbers
hendrik.ebbers at me.com
Wed Jan 2 02:08:21 PST 2013
Hi Tom,
in my opinion JFXtras is like SwingX and provides more than only new controls. At the moment there are some color utilities and animation classes next to the controls. I asked myself whats the best place for my method. Because I need it in DataFX I commited it there. This prevented DataFX from a new dependency to jfxtras. But I think it's not wrong to add such a method to JFXtras. Can I see your invokeAndWait code. We can add the best / cleanest implementation to JFXtras. Maybe JFXtras is splitted (jfxtras-core, jfxtras-controls, etc.) in future. Than DataFX can depend on it and the duplicate code will be deleted.
Hendrik
Am 02. Januar 2013 um 10:28 schrieb Tom Schindl <tom.schindl at bestsolution.at>:
I think the reason Richard provides is a weak one. I also have
situations where a syncAndWait is needed (I need it because I have to
implement an API I don't control).
Not providing an utility method because someone could do bad things with
it is not a good strategy. Yes concurrent programming is not easy and
you'd better know what you are doing else don't do it!
Not providing utilities leads to is code duplication you see now all
over the place, I have one in my library, Hendrik has one well and most
likely many others. Do jfx-extras also holds utilities or is it simply
about controls? Could we add such a method there?
Tom
Am 02.01.13 09:23, schrieb Hendrik Ebbers:
> Thanks.
>
> Am 02. Januar 2013 um 05:12 schrieb Gerrit Grunwald <han.solo at muenster.de>:
>
> Hi Hendrik,
>
> there is a comment from Richard about it that could be found here:
>
> https://forums.oracle.com/forums/thread.jspa?threadID=2370263
>
> Cheers,
>
> Gerrit
>
> Am 01.01.2013 um 23:48 schrieb Hendrik Ebbers <hendrik.ebbers at me.com>:
>
> Hi,
>
> I created a "invokeAndWait" method for JavaFX that is a equivalent of
> SwingUtilities.invokeAndWait(...). It will be part of DataFX. You can
> read about it in my blog:
> http://www.guigarage.com/2013/01/invokeandwait-for-javafx/
>
> I ask myself why there is no "invokeAndWait" method in
> javafx.application.Platform. Is there any good reason? In swing I use
> "invokeAndWait" often and so I think it is also important for JavaFX.
>
> - Hendrik
--
B e s t S o l u t i o n . a t EDV Systemhaus GmbH
------------------------------------------------------------------------
tom schindl geschäftsführer/CEO
------------------------------------------------------------------------
eduard-bodem-gasse 5-7/1 A-6020 innsbruck fax ++43 512 935833
http://www.BestSolution.at phone ++43 512 935834
More information about the openjfx-dev
mailing list