RFR: 8242523: Update the animation and clip envelope classes
Nir Lisker
nlisker at openjdk.java.net
Tue May 26 11:33:01 UTC 2020
On Mon, 11 May 2020 04:44:27 GMT, Ambarish Rapte <arapte at openjdk.org> wrote:
>> Mostly refactoring in preparation of the upcoming fixes. The changes might look like a lot, but it's mostly rearranging
>> of methods. Summery of changes:
>> ### Animation
>> * Added `isNearZero` and `areNearEqual` methods that deal with `EPSILON` checks.
>> * Added `isStopped`, `isRunning` and `isPaused` convenience methods.
>> * Added `runHandler` method to deal with running the handler.
>> * Moved methods to be grouped closer to where they are used rather than by visibility.
>> * Removed the static import for `TickCalculation`.
>> * Various small subjective readability changes.
>> * Behavioral changes: switching `autoReverse` and `onFinished` properties from "Simple" to "Base" properties; and lazily
>> initializing the `cuePoints` map.
>>
>> ### Clip Envelopes
>> * Added `MultiLoopClipEnvelope` as an intermediate parent for infinite and finite clip envelopes.
>> * Rearranged methods order to be consistent.
>> * Replaced the `checkBounds` method with a new overload of `Utils.clamp`.
>> * Renamed `pos` to `cyclePos`.
>> * Extracted common methods: `changedDirection` and `ticksRateChange`
>> * Added internal documentation.
>>
>> Also corrected a typo in `TicksCalculation` and added an explanation for an animation test.
>
> Overall looks good to me, Added few minor comments.
@kevinrushforth Do you have any other comments?
-------------
PR: https://git.openjdk.java.net/jfx/pull/196
More information about the openjfx-dev
mailing list