[jfx17] RFR: 8270314: TreeTableCell: inconsistent naming for tableRow and tableColumn property methods [v3]
Kevin Rushforth
kcr at openjdk.java.net
Sat Jul 17 15:46:52 UTC 2021
On Sat, 17 Jul 2021 15:14:41 GMT, Jeanette Winzenburg <fastegal at openjdk.org> wrote:
>> Kevin Rushforth has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Renamed updateTreeTable{Row,Column} to updateTable{Row,Column}
>
> modules/javafx.controls/src/main/java/javafx/scene/control/TreeTableCell.java line 292:
>
>> 290: new ReadOnlyObjectWrapper<TreeTableRow<S>>(this, "tableRow");
>> 291: private void setTableRow(TreeTableRow<S> value) { tableRow.set(value); }
>> 292: public final TreeTableRow<S> getTableRow() { return tableRow.get(); }
>
> this method is new, so might need a since tag - don't know how to apply it, though (because the property itself is old)
I had briefly thought about this, but didn't try it because the docs are copied from the property itself, along with any `@since` tag. I can fix this by copying the docs for the property (which is only a single sentence, so there isn't much duplication), so I'll do that.
-------------
PR: https://git.openjdk.java.net/jfx/pull/575
More information about the openjfx-dev
mailing list