RFR: 8272870: Add convenience factory methods for border and background [v2]
Ambarish Rapte
arapte at openjdk.java.net
Tue Sep 7 06:34:38 UTC 2021
On Fri, 3 Sep 2021 21:04:13 GMT, Kevin Rushforth <kcr at openjdk.org> wrote:
>> modules/javafx.graphics/src/main/java/javafx/scene/layout/Background.java line 357:
>>
>>> 355:
>>> 356: /**
>>> 357: * A convenience factory method for creating a background with a single {@code Paint}. The background will use the
>>
>> Suggestion to rephrase as:
>> `A convenience factory method for creating a Background by specifying only the {@code Paint} for BackgroundFill`
>
> Since the `Background` constructors take a list of `Paint` objects, I think saying a "single" `{@code Paint}` is helpful. I can see how adding "for `BackgroundFill`" (or maybe "as a `BackgroundFill`"?) might make it clearer.
Sound good to me, It would read like `A convenience factory method for creating a Background by specifying a single {@code Paint} as a BackgroundFill`
-------------
PR: https://git.openjdk.java.net/jfx/pull/610
More information about the openjfx-dev
mailing list