RFR: 8273946: Move clearQuad method to BaseShaderGraphics superclass

Kevin Rushforth kcr at openjdk.java.net
Tue Sep 21 12:49:59 UTC 2021


As mentioned in JBS, the `clearQuad` methods in `D3DGraphics` and `ES2Graphics` are now identical, which should have been the case all along. The fact that they weren't identical was the source of a bug that was only discovered during the testing of [JDK-8090547](https://bugs.openjdk.java.net/browse/JDK-8090547) on the es2 pipeline.

This PR moves the `clearQuad` method to the `BaseShaderGraphics` superclass to get rid of the unnecessary code duplication. This will be helpful when implementing the metal pipeline as well. As a note, I made the `context` field in the `D3DGraphics` final, which it should have been. This is necessary to ensure that moving the method to the super-class is equivalent.

No new tests are needed, since this is just refactoring.

-------------

Commit messages:
 - 8273946: Move clearQuad method to BaseShaderGraphics superclass

Changes: https://git.openjdk.java.net/jfx/pull/628/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jfx&pr=628&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8273946
  Stats: 59 lines in 3 files changed: 18 ins; 40 del; 1 mod
  Patch: https://git.openjdk.java.net/jfx/pull/628.diff
  Fetch: git fetch https://git.openjdk.java.net/jfx pull/628/head:pull/628

PR: https://git.openjdk.java.net/jfx/pull/628


More information about the openjfx-dev mailing list