RFR: 8218745: TableView: visual glitch at borders on horizontal scrolling [v6]
Marius Hanl
mhanl at openjdk.org
Thu Dec 5 09:33:48 UTC 2024
On Wed, 4 Dec 2024 12:27:54 GMT, Ambarish Rapte <arapte at openjdk.org> wrote:
>> Marius Hanl has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains six commits:
>>
>> - Merge branch 'master' of https://github.com/openjdk/jfx into 8218745-tableview-glitch-clipping-fix
>>
>> # Conflicts:
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/TableViewTest.java
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/TreeTableViewTest.java
>> - Merge branch 'master' of https://github.com/openjdk/jfx into 8218745-tableview-glitch-clipping-fix
>>
>> # Conflicts:
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/TableViewTest.java
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/TreeTableViewTest.java
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/skin/VirtualFlowTest.java
>> # modules/javafx.graphics/src/test/java/test/com/sun/javafx/sg/prism/NGNodeTest.java
>> - Merge branch 'master' of https://github.com/openjdk/jfx into 8218745-tableview-glitch-clipping-fix
>>
>> # Conflicts:
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/TableViewTest.java
>> # modules/javafx.controls/src/test/java/test/javafx/scene/control/TreeTableViewTest.java
>> - Merge branch 'master' of https://github.com/openjdk/jfx into 8218745-tableview-glitch-clipping-fix
>>
>> # Conflicts:
>> # modules/javafx.graphics/src/main/java/com/sun/javafx/sg/prism/NGNode.java
>> - Improve test
>> - 8218745: TableView: visual glitch at borders on horizontal scrolling
>
> modules/javafx.controls/src/main/java/javafx/scene/control/skin/VirtualFlow.java line 3226:
>
>> 3224: clipRect.setLayoutY(snappedY);
>> 3225: }
>> 3226:
>
> The method names sound a little confusing to me. The methods only set the values for clip rect and clip view.
> The hbar.getValue() represents the x value for the visible content of control.
> I would recommend to rename these methods to something as, setClipLayoutX or setClipX..
I chose this name to be consistent with the `ScrollPaneSkin`, but I agree that this is not the best name.
`setClipLayoutX` sounds good to me, will change.
-------------
PR Review Comment: https://git.openjdk.org/jfx/pull/1462#discussion_r1870992107
More information about the openjfx-dev
mailing list