RFR: 8344114: Remove obsolete permission check methods from Font classes [v2]
Lukasz Kostyra
lkostyra at openjdk.org
Mon Dec 9 13:36:02 UTC 2024
On Mon, 9 Dec 2024 12:45:56 GMT, Lukasz Kostyra <lkostyra at openjdk.org> wrote:
>> modules/javafx.graphics/src/main/java/com/sun/javafx/font/PrismFontFactory.java line 1375:
>>
>>> 1373: if (FontFileWriter.hasTempPermission()) {
>>> 1374: return loadEmbeddedFont0(name, fontStream, size, register, loadAll);
>>> 1375: }
>>
>> This test always returns true today, so it looks like you removed the code path that was in use. Unless I'm missing something, I think that you should restore the "return loadEmbeddedFont0" call and remove everything else below this point from this method.
>
> Yes, this should always `return loadEmbeddedFont0`. Again, some Friday-related mishap.
I went a step further even - now with `loadEmbeddedFont` essentially only calling `loadEmbeddedFont0` this is the only place where `loadEmbeddedFont0` is used. I decided to remove this code altogether and rename `loadEmbeddedFont0` to appropriate `loadEmbeddedFont`. Tests seem to be all good after this change.
-------------
PR Review Comment: https://git.openjdk.org/jfx/pull/1659#discussion_r1875988521
More information about the openjfx-dev
mailing list