RFR: 8313424: JavaFX controls in the title bar [v65]

Markus Mack mmack at openjdk.org
Thu Apr 24 15:10:11 UTC 2025


On Thu, 24 Apr 2025 14:36:52 GMT, Michael Strauß <mstrauss at openjdk.org> wrote:

>> modules/javafx.graphics/src/main/native-glass/mac/GlassWindow.h line 53:
>> 
>>> 51:     BOOL                isDecorated;
>>> 52:     BOOL                isResizable;
>>> 53:     BOOL                isStandardButtonsVisible;
>> 
>> showStandardButtons? The surrounding code does not seem to follow a strict "isXyz" naming convention for bools, so we could improve grammar here.
>
> Except for `suppressWindowMoveEvent` and `suppressWindowResizeEvent`, the code does seem to follow the "isFoo" convention...

There are also the canBecomeMainWindow, hidesOnDeactivate, worksWhenModal methods below

>> modules/javafx.graphics/src/main/native-glass/win/GlassWindow.cpp line 617:
>> 
>>> 615:         // Since DefWindowProc() is not called, call the mouse menu handler directly
>>> 616:         HandleViewMenuEvent(GetHWND(), WM_CONTEXTMENU, (WPARAM) GetHWND(), ::GetMessagePos ());
>>> 617:         //::DefWindowProc(GetHWND(), msg, wParam, lParam);
>> 
>> Space after GetMessagePos, leftover code comment?
>
> I think the comment is there to drive the point home that `DefWindowProc` is not called? It's pre-existing code that I've just moved around.

I see it's the same in FullScreenWindow.cpp, so I agree to leave it as an exact copy to make refactoring easier if this is ever de-duplicated.

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/1605#discussion_r2058670673
PR Review Comment: https://git.openjdk.org/jfx/pull/1605#discussion_r2058665551


More information about the openjfx-dev mailing list