RFR: 8313424: JavaFX controls in the title bar [v49]
Michael Strauß
mstrauss at openjdk.org
Fri Feb 14 14:54:28 UTC 2025
On Fri, 14 Feb 2025 14:08:34 GMT, Thiago Milczarek Sayao <tsayao at openjdk.org> wrote:
> Does the name `EXTENDED` accurately reflect its functionality? I have a feeling there's a better name for it.
Here are some alternatives:
* `FULL_SIZE`, like in AppKit's `NSWindowStyleMaskFullSizeContentView`
* `COMBINED`, meaning that non-client and client areas are combined
* `UNIFIED` already exists, but is non-functional; we could repurpose it
-------------
PR Comment: https://git.openjdk.org/jfx/pull/1605#issuecomment-2659531910
More information about the openjfx-dev
mailing list