[vector] maskFromArray Intrinsic
Deshpande, Vivek R
vivek.r.deshpande at intel.com
Fri Nov 9 01:00:28 UTC 2018
Hi Vladimir
Other than changing the type of return in vmSymbols.hpp there is no change in the JVM.
I have made the suggested name change to LoadOperation.
The patch is here:
http://cr.openjdk.java.net/~vdeshpande/VectorAPI_maskFromArray/webrev.01/
Let me know what you think and I can push it by tomorrow.
I have tested the patch with unit tests in vector API.
Regards,
Vivek
-----Original Message-----
From: Vladimir Ivanov [mailto:vladimir.x.ivanov at oracle.com]
Sent: Wednesday, November 7, 2018 5:41 PM
To: Deshpande, Vivek R <vivek.r.deshpande at intel.com>; panama-dev at openjdk.java.net
Subject: Re: [vector] maskFromArray Intrinsic
No changes on JVM side needed, right?
src/jdk.incubator.vector/share/classes/jdk/incubator/vector/VectorIntrinsics.java:
- interface LoadVectorOperation<C, V extends Vector<?,?>> {
+ interface LoadVectorOperation<C, V> {
V load(C container, int index);
}
Maybe rename it to LoadOperation then?
Otherwise, looks good.
Best regards,
Vladimir Ivanov
On 07/11/2018 17:33, Deshpande, Vivek R wrote:
> Hi All
>
> I have a patch for maskFromArray intrinsic. It reuses intrinsic for load.
> The changes are mainly on the jdk side.
> The webrev is here:
> http://cr.openjdk.java.net/~vdeshpande/VectorAPI_maskFromArray/webrev.00/
> Could you please review the patch.
>
> Regards,
> Vivek
>
More information about the panama-dev
mailing list