[foreign-memaccess] RFR 8226527: Add package-info javadoc
Maurizio Cimadamore
maurizio.cimadamore at oracle.com
Thu Jun 27 13:37:46 UTC 2019
Hi
i've done a comprehensive pass over the javadoc of the memory access
API, to add a package-level javadoc, and also to improve the quality of
the javadoc pretty much across the board.
The patch is here:
http://cr.openjdk.java.net/~mcimadamore/panama/8226527/
Or, if you prefer, a link to the new API javadoc is here:
http://cr.openjdk.java.net/~mcimadamore/panama/memaccess_javadoc_v2
I've also did some minor tweaks on some API points, to make them more
consistent - to name a few:
- renamed GroupLayout.struct/union to ofStruct/ofUnion
- renamed the methods in MemoryAccessVarHandle to make it more
consistent with naming convention in the combinators defined in
MethodHandles
- removed references to 'endianness' and replaced with 'order' (this is
what ByteBuffer does, I think it's better to stick with existing trends)
- removed some of the 'Kind' enums which were not adding a lot of value.
They are still there in the impl, but they are no longer exposed. We can
always do so e.g. if we decided to add way more value layout kinds.
The resulting API feels pleasingly compact and tight (but yet expressive).
Comments welcome.
Maurizio
More information about the panama-dev
mailing list