[foreign-memaccess] RFR 8223786: Rename layout annotation to layout attribute
Maurizio Cimadamore
maurizio.cimadamore at oracle.com
Mon May 13 18:05:18 UTC 2019
The term 'annotation' is too polluted when it comes to Java. Replacing
it with something more neutral like 'attribute' could work better:
http://cr.openjdk.java.net/~mcimadamore/panama/8223786/
This is a good first step, but longer term I'm also considering dropping
annotations and have layout names, size and alignment to be modeled more
directly in the API. After all, the only reason why we need layout
attributes at all in this API is to express alignment constraints; in
the next few days I'll put together a prototype which implements
alignments checks - and see whether it's feasible to expose alignment as
a first class property of layouts (as sizes are).
Maurizio
More information about the panama-dev
mailing list